How to Reset ZD password using SNMP OID

Summary

Customer asks for help to recover/reset the ZD admin password credentials since they do not remember it or previous admin has left. Procedure requires a Write SNMP string.

Question

Can Ruckus help recover/reset a lost ZD admin password?

Customer Environment

ZD 3K ZD

Root Cause

Forget admin Password, Lost ZD admin password or previous engineer left.

Workaround

You can only reset an existing ZD password from a ReadWrite(RW) SNMP string, if backup available it can be recovered with help of TAC.
or else the ZD must be factory defaulted, erasing previous password and configuration.
 

OID for resetting admin password.
SNMP OID

SNMP MIB ref article

https://support.ruckuswireless.com/articles/000004433

Resolution

If Customer has details of the write SNMP community string available with them and SNMP server which can be used to set new admin password.

Commands on SNMP server.
snmpset -v 2c -c SNMPSTRING <DEVICEIP> <OBJECTNAME/OID> s    " abcd" {For string}
e.g.
root@SNMPSERVER:~# snmpset -v 2c -c Write123 10.161.95.3 .1.3.6.1.4.1.25053.1.2.1.1.1.1.26.0 s "test"

 

If String is a read only, you might get error:

root@SNMPSERVER:~# snmpset -v 2c -c Read123 10.161.95.3 .1.3.6.1.4.1.25053.1.2.1.1.1.1.26.0 s "test"
Error in packet.
Reason: notWritable (That object does not support modification)

type - one of i, u, t, a, o, s, x, d, n
i: INTEGER, u: unsigned INTEGER, t: TIMETICKS, a: IPADDRESS
o: OBJID, s: STRING, x: HEX STRING, d: DECIMAL STRING
U: unsigned int64, I: signed int64, F: float, D: double


 

Related Articles

000002982, 000004433

Article Number:
000011974

Updated:
December 11, 2025 06:10 AM (4 months ago)

Tags:
Configuration, Security, Troubleshooting, ZoneDirector

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