H550 T750 T350D 116.0.0.0.1506 - Unable to perform local upgrade from web UI

Summary

Unable to perform a local upgrade on H550 using web UI from 116.0.0.0.1506 to any version.

Question

Why I couldn't upgrade the H550 solo AP to any firmware version locally?

Customer Environment

The customer has a closed environment and has a static IP assigned to the AP H550 and is trying to upgrade the firmware from 116.0.0.0.1506 to 118.2.0.0.875 using the local upgrade option.

Root Cause

This issue is happening due to failure in resolving the domain name because the AP has static IP configured and when the AP has static IP configured there is no DNS server configured on it. Due to this reason the AP is not able to resolve the domain name-fwupdate1.ruckuswireless.com. 

Troubleshooting Steps

The customer has an H550 AP assigned with static IP and is trying to upgrade the AP from standalone version 116.x in a closed environment using the local upgrade option. It fails with the error "Failure Reason: [AP RFW: Unable to resolve the hostname for control file download]".

 

 

Workaround

This issue is resolved in the next solo release 118.x. However, to upgrade from the 116.x version we can use the below workarounds.
 
  • Set the FTP server IP to any dummy IP, and save the parameters. Try to upgrade again using the local upgrade option.
  • We can also try upgrading the firmware using AP CLI (ssh).
  • We can also try upgrading after configuring the DNS server option manually from AP CLI using the "set dns ipv4 <valid DNS server>”.


 

Resolution

This issue is resolved in the next solo release 118.2.0.0.875.

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000001297, 000001866

Article Number:
000014422

Updated:
September 19, 2024 11:27 PM (3 months ago)

Tags:
Firmware, Troubleshooting, Known Issues and Workarounds, ZoneFlex Indoor

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