Intermittent browsing failures on Apple devices

Summary

This article discusses web page load failures on Apple devices and a method to address it.

Question

Why web pages fail to load on Apple devices while Windows devices don't have any issue? What can I do about it?

Customer Environment

ZD managed wireless network

Root Cause

Apple devices are sensitive to DNS response times. Due to this, they tend to show page can not be found errors more rapidly than Windows clients.

Troubleshooting Steps

Following steps can be used to narrow down this browsing issue:
1. Issue is exclusively seen on Apple clients
2. Problem is intermittent
3. Refresh of the page fixes the issue

The problem is most possibly due to slow response to DNS queries. Solution is to use external OpenDNS or Google DNS servers on the client. Please use the resolution steps listed below to make the relevant changes.

Workaround

Change the DNS server's IP to OpenDNS or Google DNS IPs.

Resolution

Following steps explain the DNS server IP address change on an iOS device:
1. Tap on the "Settings" from the home screen
2. Tap on Wi-Fi and click on the blue arrow right next to your desired wireless network
3. You will find DNS server setting under the DHCP tab
4. Change the DNS server IPs to either the OpenDNS (208.67.222.222 and 208.67.220.220) or Google DNS (8.8.8.8 and 8.8.4.4).

The Google Public DNS IP addresses (IPv4) are as follows:
- 8.8.8.8
- 8.8.4.4
The Google Public DNS IPv6 addresses are as follows:
- 2001:4860:4860::8888
- 2001:4860:4860::8844
You can use either address as your primary or secondary DNS server.

More detailed instructions including the screenshots can be found at http://www.macinstruct.com/node/558

You need to make similar setting changes on MacBooks as well if the browsing failures are noticed on OS X platform as well.

Just as an additional note, these setting changes are recommended at an Apple Forums page. Please find this discussion at https://discussions.apple.com/message/24884041#24884041 We found the DNS setting change had a positive impact at one of the customer sites.

Article Number:
000002823

Updated:
September 15, 2020 06:58 PM (about 4 years ago)

Tags:
Configuration, Troubleshooting, Known Issues and Workarounds, ZoneDirector

Votes:
12

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