Clients do not get an IP and new APs can't join the ZD

Summary

Some network switches offer MAC limitation per port. Once this limit has reached it will start dropping traffic for new connections. This can have severe impact on clients as well as on AP connectivity.

Question

Why can't any new client connect while the existing clients don't seem to have any issues?

Customer Environment

ZD managed or standalone AP

Root Cause

Customer has an existing switch port configuration that limits MAC addresses that can be learned

Troubleshooting Steps

Here are the steps that will assist with client connectivity issue specific to a switch port configuration:
1. Make sure existing client's connection is fine
2. Connect a new client (using same known-to-work settings) to a working AP
3. If the new client fails to connect, disconnect and reconnect the existing client
4. If the new client still fails, verify port settings on the switch AP is connected to
5. Check if there is any MAC address limitation setting. If there is one, make sure this value is not exceeded.
6. Verify this setting both on switch's uplink port as well as on the upstream switch.

Other connection and DHCP IP address failure reasons include:
1. Wrong configuration either on the ZD/AP or on the client
2. Wrong VLAN assignment
3. Lack of DHCP server or exhausted DHCP pool
4. Client configured with an inappropriate static IP or gateway
5. DNS issues

Resolution

After raising the MAC address limitation or disabling such setting will remove all obstacles in getting new clients connected and APs stay connected to the ZD.

Article Number:
000002705

Updated:
May 05, 2021 01:33 AM (over 3 years ago)

Tags:
Configuration, Troubleshooting, Known Issues and Workarounds, ZoneDirector, ZoneFlex Indoor, ZoneFlex Outdoor

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