How to influence client load balancing?

Summary

This article explains what parameters are available in case the default client load balancing doesn't do the expected job.

Question

What parameters are available to influence client load balancing?

Customer Environment

ZoneDirector managed wireless network

Root Cause

Default client load balancing didn't meet the expectations.

Troubleshooting Steps

Here are few facts about client load balancing:
1. It is enabled by default
2. Setting can be found under the Configure --> Services page. It can be disabled altogether if not required. Only tweakable parameter that is exposed to the GUI is adjacent radio threshold which references signal strength from neighboring AP.
3. It can also be disabled at the SSID level by going to WLAN's advanced setting.
4. Background scanning must be enabled for this feature to work
5. It works by withholding probe and authentication responses from the AP

More details can be found inside the article available at https://support.ruckuswireless.com/answers/000003211

To add, load balancing can be configured via CLI. Here is the CLI path to find available parameters. Please note that these need to be configured at the radio level.
Please login: admin
Password:
Welcome to the Ruckus Wireless ZoneDirector 3000 Command Line Interface
ruckus> en
ruckus# con
You have all rights in this mode.
ruckus(config)# load-balancing
ruckus(config-load-balancing)# show <-- This will show current settings for both radios
ruckus(config-load-balancing)# ?

There may be conditions where the load balancing doesn't work as per the expectations. They include:
1. High concentration of clients in a particular physical location
2. One latest model AP with improved antenna technology and an old AP model are neighbors
3. Client specific behavior during roaming or initial association which will prevent it from connecting to a far AP

Resolution

To handle such scenarios, following parameters can be considered:
1. Adjacent Threshold: This parameter is available via GUI as well as through CLI which controls load balancing based on signal level seen from neighboring APs.
2. Activation Threshold: This parameter sets the value for client count above which client load balancing will initiate. This setting is available only via CLI.
3. Weak Bypass: If the client signal level is below this RSSI, AP will not take action to influence the client connection. This setting is available only via CLI.
4. Strong Bypass: If the client signal level is above this RSSI, AP will not take action to influence the client connection. This setting is available only via CLI.

Other alternatives to the above software settings include:
1. Repositioning of APs
2. Adjusting power levels
3. Making use of SmartRoam feature. This is explained in KB article available at https://support.ruckuswireless.com/answers/000002277

Please note that Band Balancing (or Band Steering) is different from this as it works at the AP level (instead between neighboring APs) to balance clients between 2.4 GHz and 5 GHz radios.

Article Number:
000003632

Updated:
August 18, 2020 03:36 AM (over 4 years ago)

Tags:
Performance, Configuration, Troubleshooting, ZoneDirector

Votes:
2

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