Error while accessing the DPSK pool in Cloudpath
Summary
This article explains the details of the error encountered while accessing the DPSK pool in Cloudpath, where the system displays the message "Error Occurred".Question
Cloudpath error in accessing DPSK pool?Customer Environment
Cloudpath Enrollment System with DPSK pool configuration.Symptoms
DPSK pool will not be visible from GUI and will give error (An exception occurred).
NOTE: It will not stop the functionality/authentication from the Pool.
Root Cause
This document is helpful in identifying issue with DPSK pool where DPSK pool isn't visible from the CP GUI due to DPSK corruption issue.Troubleshooting Steps
1.Select DPSK Pool from the Configuration Tab.
2. Select affected DPSK Pool from the list.
3. Select DPSK from the DPSK Pool.
4. Error as below.
Workaround
Access the DPSK using the API
Reference API Guidehttps://support.ruckuswireless.com/documents/3591-cp_es-5-8-ga-rest-api-user-guide
Step 1: Collect token ID first.
Request Type: POST
https://{CPIP}/admin/publicApi/token
Body
{
"userName": "[email protected]",
"password": "password"
}
e.g. API Call
Step 2: API Call for checking DPSK
Request Type: GET
https://CP_IP/admin/publicApi/dpskPools/{GUID}/dpsks?pageSize=100
{GUID} : Modify Guid from DPSK Pool as below
use token value from Step 1 under Headers
Authorization : tokenvalue
e.g. API Call
IMPORTANT: Collect the output DPSK information and save the data, now you will need to look into the DPSK data to find out if any of the DPSK is corrupted.
Step3: How to identify Corrupt DPSK
The DPSK data will not show full information of the DPSK, any value might be wrong inside it, incorrect data or missing data, like : status, expiration date, deviceCount etc for a single or multiple DPSK.
e.g. Corrupt DPSK as below
{"guid":"AccountDpsk-b8e9b0da-59cb-47df-9863-d95f8sdjfdkja","name":"Corrupt DPSK ","passphrase":"********","status":"ACTIVE","ssidList":[],"useDeviceCountLimit":true,"deviceCountLimit":75,"deviceCount":0,
Step 4: Delete the DPSK from the pool using DELETE API, if the corrupt DPSK is identified.
Request Type: DELETE
https://CP_IP/admin/publicApi/dpskPools/{GUID}/dpsks?/{DPSKGUID}
{GUID} : Same as Step 2.
{DPSKGUID} :AccountDpsk-b8e9b0da-59cb-47df-9863-d95f8sdjfdkja of the corrupted DPSK as above.
e.g. API Call
Once Corrupted DPSK data is deleted from the DPSK pool, all DPSK information will be visible from the GUI.
Resolution
NOTE: The cause of the DPSK corruption was un-identified from the Cloudpath logs, so for now we are using this as a workaround.
Article Number:
000012269
Updated:
January 09, 2026 01:19 PM (16 days ago)
Tags:
Troubleshooting, Known Issues and Workarounds, Cloudpath
Votes:
1
This article is:
helpful
not helpful