Why is captive portal appearing to be in a loop in ACX or vSZ managed AP after entering the credentials

Summary

Explanation on one of the causes of authentication not succeeding . This is a simple solution but one that could be missed in the Cloud and vSZ environments

Question

Why is captive portal appearing to be in a loop after entering the credentials

Customer Environment

Cloud - ACX Environment SZ vSZ AP - Any model Cloudpath (or a similar Captive Portal solution)

Root Cause

Walled garden for the ACX or vSZ POST URL is not entered in the WLAN

Symptoms

No specific error message, but after customer enters credentials on the Captive Portal, the webpage circles back to the same screen prompting credentials again

Troubleshooting Steps

- Checked Cloudpath configuration
- Checked Reachability between all nodes: AP, Cloudpath, Cloud, vSZ

Resolution

Add the below entry to the walled garden list of the WLAN
*.ruckus.cloud


Explanation: ACX listens on the below URL during POST authentication phase of redirection:
https://<tenantID>.wispr.ruckus.cloud/SubscriberPortal/hotspotlogin  







If the above entry is not present in the walled garden, POST redirection process will keep looping and come back to the same screen over and over. 

Similarly in case of vSZ managed APs, add the vSZ controller's management IP in the walled garden list.

Explanation: vSZ listens on the below URL during POST authentication phase of redirection. 


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Article Number:
000014009

Updated:
September 03, 2024 03:08 AM (3 months ago)

Tags:
Configuration, Troubleshooting, Known Issues and Workarounds, Cloud Services

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