Cloudpath and Meraki Splash Page issues
Summary
Clients using the Cloudpath workflow with Meraki APs are stuck in an infinite loop of redirection accessing the redirect URL.Question
How to configure redirect URL on cloudpath for Cisco Meraki?Customer Environment
Cisco Meraki AP using an external splash page on Cloudpath.Symptoms
Cisco Meraki AP using external splash page hosted on cloudpath gets infinite redirection on redirect URL step of the workflow.CP workflow:
Root Cause
The "too many redirects" error occurs because the client is redirected by the splash server to the EXCAP splash page, but the client isn't allowed to access the splash page. This means when client hits redirect step in the cloudpath workflow it still in unauthenticated state. Hence, there is specific format to let the Meraki AP know that client has been authenticated.Resolution
As per the official guide from the Meraki Team, below is the format to be used to move the client from an unauthenticated to an authenticated state and let them access the redirect URL:
GET[‘base_grant_url’] + “?continue_url=” + GET[‘user_continue_url’]
base_grant_url = https://n##.meraki.com/splash/grant
user_continue_url = http://google.com
Where base_grant_url
is the Meraki cloud URL and user_continue_url
is the URL to which the user will be redirected.
In the case of the example above, the assembled URL would be:
https://n##.meraki.com/splash/grant?continue_url=https://google.com
Related Articles
https://meraki.cisco.com/lib/pdf/meraki_whitepaper_captive_portal.pdfArticle Number:
000014693
Updated:
June 25, 2025 12:16 PM (5 days ago)
Tags:
Configuration, Cloudpath
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