How to support new R300 in SZ above 5.x

Summary

R300 does not support SZ versions 5 and above, however, we can still bring up the device with the multiversion support feature in SZ using a dedicated zone in older version

Question

How to bring up R300 when the SZ network is upgraded to 5.x

Customer Environment

SZ in 5.1.1 Previously upgraded from 3.6.2.0.222 AP models: R300, R320 Zone in use: default zone and a customized zone Default zone in 5.1.1.x Custom zone in 3.6.2 New R320s can come up, however, no new R300s were able to come up

Root Cause

Unable to bring new AP R300 as the default zone version is an unsupported higher version with respect to R300

Symptoms

Default zone is in a higher version than the AP supported version
Default zone in 5.1.1.x
Custom zone in 3.6.2
Wsgclient log

Jul 31 14:13:53 wsgclient 532 Error: httpRecv:315 http status is 502
Jul 31 14:13:53 wsgclient 532 Error: crHttpRequestWithAuth:472 ret:117
Jul 31 14:13:53 wsgclient 532 Error: registration:807 Failed to send Discovery packet! ret:117
 
Cannot open /proc/afmod/stats: No such file or directory
 
 
RSM log
Jul 31 14:17:14 RSM ERR @ PID:333:rsm_wsgclient.c:1434 rsm_wsgclient_pgetZoneUUID failed ret 6, bad key: wsgclient/zone-id
 
Jul 31 14:17:29 RSM ERR @ PID:1309:rsm_tunnelmgr.c:1343 rsm_tunnelmgr_init: File not found: /tmp/tunnelmgr_time
 

Troubleshooting Steps

  • The reported AP is the only R300 available in the network
  • From the previous support logs shared, we could validate that the AP has SZ version 3.6.2.0.695 in it
  • This was previously connected to the same SZ and then was removed from the network and the device was also removed from the SZ
  • The AP was in 192.168.18.0/24 subnet, and we did not have any spare AP in the same subnet
  • The following wsg client log and RSM log show that the AP is unable to communicate to the controller

WSGclient log:

Jul 31 14:13:53 wsgclient 532 Error: httpRecv:315 http status is 502

Jul 31 14:13:53 wsgclient 532 Error: crHttpRequestWithAuth:472 ret:117

Jul 31 14:13:53 wsgclient 532 Error: registration:807 Failed to send Discovery packet! ret:117

Cannot open /proc/afmod/stats: No such file or directory

  

RSM log:

Jul 31 14:17:14 RSM ERR @ PID:333:rsm_wsgclient.c:1434 rsm_wsgclient_pgetZoneUUID failed ret 6, bad key: wsgclient/zone-id

Jul 31 14:17:29 RSM ERR @ PID:1309:rsm_tunnelmgr.c:1343 rsm_tunnelmgr_init: File not found: /tmp/tunnelmgr_time

 
  • Validated the zone information and could see that the default zone was in use general with 5.1.1.x
  • Hence we created an AP registration rule to facilitate the particular IP to provision the alternate zone which is in 3.6.2.

Workaround

    • System >> AP Settings >> AP Registration >> Create new Rule >> Provide the range of AP IPs >> Choose the zone
  • The AP came up successfully

Resolution

AP registration rule to provision the AP to the zone running in supported lower version 
 

Article Number:
000010793

Updated:
September 21, 2020 07:09 AM (about 4 years ago)

Tags:
Configuration, SmartCell Gateway

Votes:
0

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