Actions to take in case of DHCP Decline message from the client

Summary

This article explains what causes DHCP Decline response from a client, how to diagnose the problem, and what needs to be done to fix the issue.

Question

What to do when DHCP Decline response message is received from a client?

Customer Environment

Ruckus wireless network with DHCP server

Root Cause

Either duplicate IPs or not enough scope to support client volume.

Troubleshooting Steps

One of the symptoms in such environments will be client repeatedly gets a different IP every few seconds.
Looking at a network packet capture, client goes through normal DHCP discovery and request process. But there will be a DHCP Decline response from the client later to the above steps.
Scrolling a bit within the packet capture, there will be a gratuitous ARP from the client enquiring if there is anyone holding same IP (also indicating everyone which IP it got from the server). Following the gratuitous ARP, there will be  an ARP response from a different client indicating it has the same IP. That's an indication that the client has received a duplicate IP. This will cause the client to send a DHCP Decline and start DHCP process all over again.

DHCP server event messages will have an indication of "This address is already in use". Packet capture will also have packets that show 'duplicate use of IP detected' messages.

Resolution

1. Increase DHCP scope to avoid duplication.
2. If there are manually assigned IPs causing the duplication, avoid manual assignment or exclude those IPs from dynamic assignment.

Article Number:
000003789

Updated:
August 09, 2020 11:27 PM (over 3 years ago)

Tags:
Troubleshooting, Known Issues and Workarounds, Unleashed, ZoneDirector, ZoneFlex Indoor, ZoneFlex Outdoor, SmartCell Gateway, virtual SmartCell Gateway

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10

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