Clients behind a Third Party wireless bridge are unable to obtain a DHCP IP address

Summary

This article discuss about the solution for wireless clients which are behind the third party wireless bridge which in turn connected to the Ruckus Access point over wireless are unable to obtain an IP address from a DHCP server.

Question

Why clients behind a Third Party device cannot get IP address ?

Customer Environment

Zone Director Smart Zone 3.6 and higher ASUS WL-330gE Bridge IOGEAR Ethernet-2-WiFi GWU637

Root Cause

In recent Firmware versions we made some changes in the way clients request for a DHCP IP by making the DHCP request as Unicast instead of a Broadcast. Due to this, some clients have issues in acquiring IP addresses. For any client that has the broadcast bit set in the bootp packet of DHCP – they do not like to receive unicast DHCP offer or ack’s (Windows Vista, Windows 7 alternating requests, Wireless client bridge devices)

Troubleshooting Steps

ssh into the rukus AP where the client bridge is associated to and run the following AP CLI command
1) Confirm directed dhcp enabled

rkscli: get qos
Tx Failure Threshold:      50           Dead Station Count: 35

Directed DHCP:             Enabled  <--- Confirm this is enabled
<-- snippit -->

2) Disable directed dhcp

rkscli: set qos directedDHCP disable
Direcet DHCP is Disabled
OK

rkscli: get qos
Tx Failure Threshold:      50           Dead Station Count: 35

Directed DHCP:             Disabled  <--- Confirm this is disabled
<-- snippit -->

3)Set your wired laptop back to DHCP mode and test for DHCP IP address.

4) Restore Directed DHCP

rkscli: set qos directedDHCP enable
Direcet DHCP is Enabled

rkscli: get qos
Tx Failure Threshold:      50           Dead Station Count: 35

Directed DHCP:             Enabled  <--- Confirm this is enabled

 

Workaround

  • Set static IP address

Resolution

  • We disabled the directed DHCP by running the below commands on CLI mode of Zone Director or Smart Zone products thereby making the DHCP request as Broadcast instead of Unicast.
  • SSH into the controller using a SSH client like "Putty" or "TeraTerm" and execute the below commands: 
  • Zone Director
Single AP
rkscli: set qos directedDHCP disable

All AP
ruckus>en 
ruckus#debug 
ruckus(debug)# remote_ap_cli -A "set qos directedDHCP disable"    ----> This command disables this feature across all the connected Access points

Note: These commands will remain in effect even if the ZD is restarted
  • Smart Zone
Single AP
rkscli: set qos directedDHCP disable

ALL AP
Use AP CLI script feature on the controller to propagate " set qos directedDHCP disable "

Note: These commands will remain in effect even if the SZ is restarted

Article Number:
000001423

Updated:
December 10, 2019 10:50 AM (about 1 month ago)

Tags:
Troubleshooting, Known Issues and Workarounds, ZoneDirector, SmartCell Gateway

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